关于行会自定义变量重启后失效的问题
我用行会自定义变量扩展了一下行会功能. 在服务器重启后, 点击NPC只显示??我用GM号退出行会,重新建立新行会后, 又能正常显示
我用测试服务器, 重复了几次都是, 新建的行会没有任何问题. 上下线都正常显示NPC的内容.
但只要重启了服务器, NPC就会显示两个问号
目前唯一的办法就是重新VAR一下行会变量.
但那样的话, 之前储存的数据就都被清零了.
这是引擎的设定就是如此,还是我没有找对方法?
简单的登录时申明一个变量:
var integer guild 测试
LOADVAR guild 测试 ..\\QuestDiary\\行会变量.txt
然后NPC或脚本进行操作:
#ACT
CALCVAR guild 测试 + 5
SAVEVAR guild 测试 ..\\QuestDiary\\行会变量.txt
注意红色的为设置字符变量还是数字变量。
执行后看看文本里是否保存了,然后再重启服务器。
看看错误原因。出现?号一般是上线没有申明变量 行会变量一直都是有问题的,放弃用行会变量把! 442671 发表于 2020-11-6 21:24 简单的登录时申明一个变量:
var integer guild 测试
LOADVAR guild 测试 ..\\QuestDiary\\行会变量.txt
是的没错, 重新申明一下, 然后loadvar重新赋值一下就解决了.
页:
[1]